网络工程师——组网技术(一)

交换路由基础知识

交换机简介和分类:交换机(Switch)意为“开关”是一种用于电(光)信号转发的网络设备。它可以为接入交换机的任意两个网络节点提供独享的电信号通路。工作于第2层或第3层。最常见的交换机是以太网交换机。下图是Huawei S2700系列以太网交换机。

交换机分类:有多种分类方法如下

交换机堆叠和级联:形如并联,串联

交换机典型三级:

  1. 接入层交换机,如S2700。
  2. 汇聚层交换机,S3700。
  3. 核心层交换机,如S5700。

交换机性能参数和计算公式:

  • 包转发率:端口吞吐率,64字节数据包转发能力,单位pps(包/秒)。
    计算公式如下:
    包转发率=千兆端口数×1.488Mpps+百兆端口数×0.1488Mpps+其余端口×相应包转发pps
  • 背板带宽:端口处理器和数据总线之间单位时间内传输的最大数据量。单位Gbps(吉比特/秒)。
    计算公式如下:
    总带宽=端口数×端口速率×2(全双工)

路由器简介和分类:路由器(Router)用来连接不同的局域网,路由器可以学习和传播各种路由信息,并根据这些路由信息将网络中的分组转发到正确的网络中。路由器工作在第3层网络层,具有局域网和广域网两种接口。通过路由表为进入路由器的数据分组选择最佳的路径,并将分组传输到适当的端口。

路由器根据功能、性能、应用分为:

  1. 骨干路由器:主干网络互联,模块化、热备份、双电源等冗余技术。如国家级、省级骨干网互连。如NE40E以上系列。
  2. 企业级路由器:用于一个企业出入口,提供多种功能,完成企业组网。可实现数据、语言、视频等应用。如AR3600系列。
  3. 接入级路由器:边缘路由器,小型企业,或者部门组网。如AR2200系列

路由器上的一些常见端口:

  1. Serial端口:高速同步串口,与广域网连接,可连接DDN、帧中继、X.25、PSTN等网络。
  2. Console端口:初次配置控制台端口,利用终端仿真程序,如超级终端、SecureCRT对路由器进行本地配置。
  3. RJ-45端口:以太网口,通过双绞线连接局域网,有的标识ETH,有的标识为10/100 b TX。
  4. AUX端口:远程配置路由器,连接Modem。

交换路由的操作系统VRP:是华为公司为其网络设备开发的操作维护系统。用户通过运行命令行CLI,对网络设备进行功能设置。

访问交换机和路由器的几种方法:

  1. Console口,初次配置。
  2. AUX口远程拨号。
  3. Telnet带外远程。
  4. Web浏览器输入IP。
  5. 网管软件。

交换和路由中的广播域和冲突域:

  • 冲突域:在同一个冲突域中的每一个节点都能收到所有被发送的帧。简单的说就是同一时间内只能有一个设备发送信息的范围。
    交换机分隔冲突域。一个端口一个冲突域
  • 广播域:网络中能接收任一设备发送的广播帧的所有设备的集合。简单的说如果站点发出一个广播信号,所有能接收收到这个信号的设备范围称为一个广播域。
    路由器能分隔广播域。一个端口一个广播域

交换机基本配置实验

交换机基础配置实验:S5700为例

交换机Console端口的默认参数如下

  • 端口速率:9600bps
  • 数据位:8
  • 奇偶校验:
  • 停止位:1
  • 流控:

配置交换机名称、管理VLAN、IP地址

//用户试图提示符
system-view //进入系统视图
[Huawei]sysname Switch1 //修改设备名称为Switch1
[Switch1]vlan 5 //创建交换机管理VLAN 5
[Switch1-vlan5]management-vlan
[Switch1-vlan5]quit
[Switch1]interface vlanif 5 //创建交换机管理VLANIF
[Switch1-Vlanif5]ip address 10.10.1.1 24 //配置VLANIF接口IP地址
[Switch1-Vlanif5]quit

配置交换机的远程登录管理Telnet:

[Switch1]telnet server enable //Telnet默认是关闭的,需要打开
[Switch1]user-interface vty 0 4 //开启VTY线路模式
[Switch1-ui-vty0-4]protocol inbound telnet //配置telnet协议
[Switch1-ui-vty0-4]authentication-mode aaa
[Switch1-ui-vty0-4]quit
[Switch1]aaa              simple 明文密码
[Switch1-aaa]local-user admin password cipher Echo@123
//配置用户名和密码,用户名不区分大小写,密码区分大小写
[Switch1-aaa]local-user admin privilege level 15

//将管理员的账号权限设置为15
[Switch1-aaa]quit
[Switch1]quit
save //在用户视图下保存配置

登录Telnet到交换机,出现如下视图提示,需要注意的是,输入密码的时候是不显示的。

telnet 10.10.1.1 //输入交换机管理IP
Login authentication
Username:admin //输入用户名和密码
Password: //输入过程中不显示
Info: The max number of VTY users is 5, and the number
of current VTY users on line is 1.
The current login time is 2020-07-14 15:05:14.
//用户视图命令行提示符

查看交换机MAC、VLAN下MAC绑定。

路由器基本配置实验

路由器基本配置实验:AR3260为例。

#设置系统的日期、时间和时区
clock timezone BJ add 08:00:00
clock datetime 15:42:00 2020-07-14

#设置设备名称和管理IP地址
system-view
[Huawei]sysname Server
[Server]interface gigabite
[Server]interface GigabitEthernet 0/0/0
[Server-GigabitEthernet0/0/0]ip add 10.137.217.177 24
[Server-GigabitEthernet0/0/0]quit

路由器静态路由实验:实现R1、R2、R3三者之间互相ping通。
第一步:首先配置各接口IP地址。
第二步:配置静态路由器命令。
第三步:再ping验证或display ip routing

在三台路由器上都执行如下接口、静态命令:

interface GigabitEthernet 0/0/1 //配置接口IP地址
ip address 10.1.1.1 24
interface GigabitEthernet 0/0/2
ip address 10.1.4.1 24
ip route-static 10.1.2.0 255.255.255.0 10.1.4.2
//配置静态路由
ip route-static 10.1.3.0 255.255.255.0 10.1.4.2
目标IP网段 下一跳路由IP

在路由器上执行命令display ip routing-table查看路由表。在PC上ping其它,可以通信即成功。

路由器静态路由IPV6实验:实现R1、R2;PC1、PC2之间互相ping通。
第一步:首先配置各接口IP地址。
第二步:配置静态路由命令。
第三步:再ping ipv6验证或display ipv6 routing。

在2台路由器上都执行如下接口、静态命令:

ipv6 //启动路由器IPV6报文能力
interface GigabitEthernet 0/0/1
ipv6 enable
//在接口上启动IPV6功能
ipv6 address 1::1 64

interface GigabitEthernet 0/0/2
ipv6 enable
ipv6 address 3::1 64

ipv6 route-static 2:: 64 3::2
//配置R1到 2:: 64网段的静态路由

在路由器上执行命令display ipv6 routing-table查看路由表。在PC上使用ping,可以通信即成功。

资源下载

VMware Workstation 建议通过官网进行下载 激活码百度即可
Workstation Pro for Windows

eNSP V100R003C00SPC200T
Windows Server 2008    
Reb Hat Enterprise 7.0

链接: https://pan.baidu.com/s/1oFOcKUl2bl-JHMoRa0_KLg
提取码:ECHO

文章作者: 鲸一
文章标题: 网络工程师——组网技术(一)
   PS: 网工系列文章整理自网络
文章链接: https://www.saroin.com/archives/1259.html
版权声明: 本博客所有文章除特别声明外,均采用知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议进行许可。转载请注明来自 鲸一
暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇