网络工程师——组网技术(二)

交换机VLAN实验

交换机GVRP:VLAN注册协议,在VLAN增加、删除、调整时,自动发广播,保持全网所有的交换机VLAN信息是一致的。

GVRP把交换机分为3种注册模式:

  1. Normal模式:VLAN增删改,广播保持一致。
  2. Fixed模式:只传播手动配置的VLAN信息。
  3. Forbidden模式:只传播VLAN1不传其他VLAN。

交换机默认:透明模式,VLAN1,所有端口。

基于接口划分VLAN:静态VLAN。

system-view //进入交换机系统视图
[Huawei]sysname SwitchA //交换机命名
[SwitchA]vlan batch 2 //批量方式建立VLAN 2
[SwitchA]interface GigabitEthernet 0/0/1 //进入交换机接口视图
[SwitchA-GigabitEthernet0/0/1]port link-type access //配置接口类型
[SwitchA-GigabitEthernet0/0/1]port default vlan 2 //将接口加入
[SwitchA-GigabitEthernet0/0/1]quit
[SwitchA]interface GigabitEthernet 0/0/2
[SwitchA-GigabitEthernet0/0/2]port link-type trunk
[SwitchA-GigabitEthernet0/0/2]port trunk allow-pass vlan 2
[SwitchA-GigabitEthernet0/0/2]quit

基于MAC划分VLAN:动态VLAN。

system-view
[Huawei]sysname SwitchA
[SwitchA]vlan batch 2
[SwitchA]interface GigabitEthernet 0/0/1 //在接口视图配置上联接口
[SwitchA-GigabitEthernet0/0/1]port link-type hybrid //配置上联接口类型
[SwitchA-GigabitEthernet0/0/1]port hybrid tagged vlan 2 //通过VLAN2
[SwitchA-GigabitEthernet0/0/1]quit
[SwitchA]interface GigabitEthernet 0/0/2 //进入交换机接口视图
[SwitchA-GigabitEthernet0/0/2]port link-type hybrid //配置接口类型
[SwitchA-GigabitEthernet0/0/2]port hybrid untagged vlan 2
//将接口加入VLAN2
[SwitchA-GigabitEthernet0/0/2]quit
[SwitchA]vlan 2
[SwitchA-vlan2]mac-vlan mac-address 22-22-22
//PC的MAC地址VLAN2关联
[SwitchA-vlan2]quit
[SwitchA]interface GigabitEthernet 0/0/2
[SwitchA-GigabitEthernet0/0/2]mac-vlan enable //基于MAC地址启动接口
[SwitchA-GigabitEthernet0/0/2]quit

基于GVRP的VLAN配置实验:可在LSW1创建VLAN2,LSW2可以学到,ping通。

第一步:交换机LSW1基本配置;LSW2参考配置。


system-view
[Huawei]un in en
[Huawei]sysname SwitchA
[SwitchA]gvrp //全局开启GVRP
[SwitchA]vlan 2 “LSW2无需配置VLAN”
[SwitchA-vlan2]int vlan 2
[SwitchA-Vlanif2]ip add 192.168.1. 254 24

第二步:交换机LSW1端口配置:LSW2参考下。

[SwitchA]int g0/0/1
[SwitchA-GigabitEthernet0/0/1]port link-type access
[SwitchA-GigabitEthernet0/0/1]port default vlan 2
[SwitchA]int g0/0/2
[SwitchA-GigabitEthernet0/0/2]port link-type trunk
[SwitchA-GigabitEthernet0/0/2]port trunk allow-pass vlan all

第三步:交换机LSW配置GVRP;LSW2参考下。

[SwitchA]sys
[SwitchA]int g0/0/2
[SwitchA-GigabitEthernet0/0/2]gvrp

第四步:配置PC1的IP,ping验证;PC2参考。

[SwitchA]dis gvrp statistics
GVRP statistics on port GigabitEthernet0/0/2
GVRP status : Enabled
GVRP registrations failed : 0
GVRP last PDU origin : 4c1f-cca6-803f
GVRP registration type : Normal

[SwitchB]dis vlan
VID Status Property MAC-LRN Statistics Description
——————————————————————-
1 enable default enable disable VLAN 0001
2 enable default enable disable VLAN 0002

交换机STP实验

交换机生成树协议STP配置:优先级

(1)配置STP基本功能。
配置环网种的设备生成数协议工作在STP模式。

#配置SwitchA的STP工作模式,SwitchB、SwitchC、SwitchD的配置相同
system-view
[Huawei]sysname SwitchA
[SwitchA]stp mode stp

配置根桥和备份根桥设备
#配置SwitchA为根桥
[SwitchA]stp root primary

#配置SwitchB为备份根桥
[SwitchB]stp root secondary

交换机生成树协议STP配置:路径值

#配置SwitchA的端口路径开销计算方法为华为计算方法,SwitchB、SwitchD配置方法相同
[SwitchA]stp pathcost-standard legacy

#配置SwitchC 端口GigabitEthernet0/0/1端口路径开销值为20000
[SeitchC]stp pathcost-standard legacy
[SeitchC]int GigabitEthernet 0/0/1
[SeitchC-GigabitEthernet0/0/1]stp cost 20000
[SeitchC-GigabitEthernet0/0/1]quit

#配置SwitchD 端口 GigabitEthernet0/0/2为边缘端口并启用BPDU报文过滤功能
[SeitchD]interface GigabitEthernet 0/0/2
[SeitchD-GigabitEthernet0/0/2]stp edged-port enable
[SeitchD-GigabitEthernet0/0/2]stp bpdu-filte enable
[SeitchD-GigabitEthernet0/0/2]quit

#配置SwitchC 端口 GigabitEthernet0/0/2为边缘端口并启用BPDU报文过滤功能
[SeitchC]interface GigabitEthernet 0/0/2
[SeitchC-GigabitEthernet0/0/2]stp edged-port enable
[SeitchC-GigabitEthernet0/0/2]stp bpdu-filte enable
[SeitchC-GigabitEthernet0/0/2]quit

设备全局启用STP,所有设备配置相同。

#设备SwitchA全局启用STP
[SwitchA]stp enable

动态路由RIP实验

动态路由RIP:距离矢量,拓扑下图

第一步:配置各接口IP:R1、R2、R3参考如下
sys
[Huawei]un in en
[Huawei]int g0/0/2
[Huawei-GigabitEthernet0/0/2]ip add 192.168.1.1 24

第二部:配置RIP协议:R1、R2、R3参考如下
sys
[Huawei]rip
[Huawei-rip-1]network 10.0.0.0 //发布该路由的IP网段
[Huawei-rip-1]network 192.168.1.0

第三步:验证配置结构:dis ip routing、ping
[Huawei]dis ip routing
Destination/Mask Proto Pre Cost Flags NextHop Interface
10.0.0.0/8     RIP  100 1  D  192.168.1.2 GigabitEthernet 0/0/2
目标网段     协议 管理距离      下一跳IP   接口

资源下载

VMware Workstation 建议通过官网进行下载 激活码百度即可
Workstation Pro for Windows

eNSP V100R003C00SPC200T
Windows Server 2008    
Reb Hat Enterprise 7.0

链接: https://pan.baidu.com/s/1oFOcKUl2bl-JHMoRa0_KLg
提取码:ECHO

文章作者: 鲸一
文章标题: 网络工程师——组网技术(二)
   PS: 网工系列文章整理自网络
文章链接: https://www.saroin.com/archives/1309.html
版权声明: 本博客所有文章除特别声明外,均采用知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议进行许可。转载请注明来自 鲸一
暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇